This is my personal neovim config.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Thamognya Kodi 2e19dba9ec
hexmode
3 months ago
.github update 4 months ago
colors everything: fix the colorscheme issue whenloading 4 months ago
licenses update 4 months ago
lua hexmode 3 months ago
.gitignore everything: fix the colorscheme issue whenloading 4 months ago
.luacheckrc everything: fix the colorscheme issue whenloading 4 months ago
.stylua.toml everything: fix the colorscheme issue whenloading 4 months ago
LICENSE.md update 4 months ago
README.md update 4 months ago
init.lua everything: fix the colorscheme issue whenloading 4 months ago

README.md

UniverseVim

A closely monitored fork of AstroNvim with pywal and improved aesthetics like using lualine, 4 space tab and etc. Made by Thamognya Kodi

= space_key -- useful key maps + ns = starts neotree + tf = starts floating terminal

Requrire nerdfont

License

SPDX-License-Identifier: MIT AND GPL-3.0-or-later

The following licenses are present in the licenses folder.


AstroNvim

AstroNvim is an aesthetic and feature-rich neovim config that is extensible and easy to use with a great set of plugins

🌟 Preview

Preview1 Preview2 Preview33

Features

Requirements

  • Nerd Fonts
  • Neovim 0.7+
  • Terminal with true color support (for the default theme, otherwise it is dependent on the theme you are using)
  • Optional Requirements:
    • ripgrep - live grep telescope search (<leader>fw)
    • lazygit - git ui toggle terminal (<leader>tl or <leader>gg)
    • NCDU - disk usage toggle terminal (<leader>tu)
    • Htop - process viewer toggle terminal (<leader>tt)
    • Python - python repl toggle terminal (<leader>tp)
    • Node - node repl toggle terminal (<leader>tn)

Note when using default theme: For MacOS, the default terminal does not have true color support. You wil need to use iTerm2 or another terminal emulator that has true color support.

Note if you are still on Neovim v0.6: You can still install the previous version of AstroNvim that supported. After cloning the repository run git checkout nvim-0.6 to check out this version. This will no longer be receiving updates.

🛠 Installation

Make a backup of your current nvim folder

mv ~/.config/nvim ~/.config/nvimbackup

Clone the repository

git clone https://github.com/AstroNvim/AstroNvim ~/.config/nvim
nvim +PackerSync

📦 Basic Setup

Install LSP

Enter :LspInstall followed by the name of the server you want to install
Example: :LspInstall pyright

Install language parser

Enter :TSInstall followed by the name of the language you want to install
Example: :TSInstall python

Manage plugins

Run :PackerClean to remove any disabled or unused plugins
Run :PackerSync to update and clean plugins

Update AstroNvim

Run :AstroUpdate to get the latest updates from the repository

AstroNvim Documentation

Watch a review video to know about the out of the box experience

Credits

Sincere appreciation to the following repositories, plugin authors and the entire neovim community out there that made the development of AstroNvim possible.

Lua